Back to overview
Downtime
Fortnite Game Update
Apr 01 at 10:15am EDT
Affected services
Fortnite
Resolved
Apr 01 at 03:21pm EDT
Updated to latest game version.
Affected services
Created
Apr 01 at 10:15am EDT
We are currently updating the Fortnite product for the latest game update.
Affected services