Back to overview
Downtime

Fortnite Game Update

Mar 25 at 10:00am EDT
Affected services
Fortnite

Resolved
Mar 25 at 01:47pm EDT

Update complete. Compensated all active users with 6 hours.

Created
Mar 25 at 10:00am EDT

Due to the Fortnite game update v34.20 we are needing to update the Fortnite product. Please stand-by as we get this completed. All users will have the time compensated.