Back to overview
Downtime
Fortnite Game Update
Mar 12, 2025 at 12:00am UTC
Affected services
Fortnite
Resolved
Mar 12, 2025 at 12:21am UTC
Updated to latest game version.
Affected services
Created
Mar 12, 2025 at 12:00am UTC
We are currently updating the Fortnite product for the latest game update.
Affected services